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 READ BEFORE USING 

Before using this product, read this Quick Start Guide and the related manuals referenced in this guide. 

Take all safety precautions and use the product correctly.

[Safety precautions for using the inverter]

WARNING
 Do not touch the terminals while power is ON. Otherwise you may get an electric shock.

 Before opening the front cover, turn OFF the power or ensure safety.

CAUTION
 If a fault occurs, immediately stop using the product.

[Detailed information]
This guide describes the basic procedures for using the PLC function. For further details, refer to the 

related manuals.

The related manuals are included in the CD-ROM packed with the product.

The manuals are also available for download at MITSUBISHI ELECTRIC FA Global Website (http://

www.Mitsubishi Electric.co.jp/fa), the Mitsubishi Electric FA network service on the world wide web.

The manuals related to this guide are shown below.

[Supplementary information]
• In this guide, operations are described using FR Configurator2 (Developer) Version 1.01. Depending on the

software version used, different menus or screens may appear.

• For consultation and inquiries concerning the PLC function, please contact your sales representative.

Manual name Manual number

FR-A800 Instruction Manual (Startup) IB-0600493

FR-A800 Instruction Manual (Detailed) IB-0600503ENG

FR-A800 PLC Function Programming Manual IB-0600492ENG

FR Configurator2 Instruction Manual IB-0600516ENG

GX Works2 Version 1 Operating Manual (Common) SH-080779ENG

Microsoft, Windows, Windows NT, and Windows Vista are registered trademarks of Microsoft Corporation in the 
United States and/or other countries.

Other company and product names herein are the trademarks and registered trademarks of their respective 
owners.
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1. How to read this guide

The following table shows the symbols used in this guide and their descriptions.

Symbol Description

This symbol indicates the necessary information.

This symbol indicates the reference manual or the page where details 
can be found.

This symbol indicates that a technical term is explained.

This symbol indicates precautions mandatory for the operation.

Point

Reference

Terminology

CONTENTS
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2. Benefits of using the Mitsubishi A800 PLC function

 Inverter operation sequence customized for the machine

 Inverter control such as inverter operations triggered by input signals, signal output according to the inverter 
operating status, and monitor output can be freely customized according to the machine specifications, which 
enhances the possibilities of the inverter. For example, for opening/closing of a shutter, a signal from a sensor is 
used to check the number of opening and closing times. By controlling the opening/closing speed, various 
shutter operations can be achieved. Control programs can be created in sequence ladders using FR 
Configurator2 (Developer).

 Optimum for the decentralized control

 The control of the whole system is decentralized to inverters, and each inverter can manage their subordinating 
devices.

 A group of dedicated sequence programs is created and saved in each inverter. Therefore, the master controller 
does not process all the sequence programs, and the decentralized system accepts program changes more 
flexibly.

 Automatic operation in accordance with the time

 With the real-time clock function, automatic operation can be performed at certain times (when the optional FR-
LU08 is used).

 User-configurable parameter, protective function, and monitor settings

 User parameter
Up to 50 user parameters can be saved. The user parameters are linked with the data registers for the PLC 
function. Therefore, changing a user parameter also changes the linked data register.

 User initiated fault
Up to five specific fault-initiating conditions can be set to activate a protective function and shut off the inverter 
output.

 User monitor setting
User-defined data can be displayed on the operation panel.

 Useful functions

 Inverter parameter read/write
Parameter settings can be changed using sequence programs. The acceleration/deceleration time and patterns 
can also be changed according to the operating status. RAM or EEPROM can be selected to save the parameter 
settings. When the settings are changed frequently, select RAM.

 PID function
Two different loops of PID inverter operations can be preset and controlled using sequence programs.

 Inverter operation lock
The inverter operation can be locked against command sources other than the sequence programs.

 Outline of the PLC function

Item Description

I/O

General-purpose I/O Sequence programs enable I/O signal transmission to/from the inverter and its plug-in options.

Analog I/O Sequence programs enable analog I/O transmission to/from the inverter and its plug-in options.

Pulse train I/O
Sequence programs enable pulse train inputs (to terminal JOG) and pulse train outputs 
(from terminal F/C (FM)).

Inverter parameter 
read/write

Sequence programs enable inverter parameter read/write.

User parameter
Fifty user parameters (Pr.1150 to Pr.1199) are available and are linked with data registers 
D206 to D255, which accept direct access by sequence programs.

CC-Link
Installing a plug-in option (FR-A8NC) enables data communication between sequence 
programs and master modules.

Special 
function

PID operation Inverter PID operations can be controlled (up to two loops) using sequence programs.

User initiated fault Up to five fault-initiating conditions can be set to activate a protective function.

Fault clear The protective function occurring in the inverter can be reset.

Inverter operation lock Inverters can start up while the PLC function is running.

User monitor setting User-defined data can be displayed on the operation panel.
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3. Before using the PLC function

 Procedure before using the PLC function

Description
Refer to 

page

Using FR Configurator2 
(Developer), create a PLC 
function project data 
model (program).

page 9

Write the created project 
data model (program) via 
a USB cable to the 
inverter.

page 17

Check the operation. page 20

Install

Personal computer + FR Configurator2 (Developer)

Project data

USB cable

A800

PLC function indicator

FWD

REV

STOP
RESET

REV

FWD

STOP
RESET

P.RUN

PU
EXT
NET

MON
PRM

IM
PM

FR-DU08

A connector
Mini B 
connector
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 Example system configuration

In this guide, the system configuration below is used as an example.

This system configuration is just an example and various other configurations are available.

Inputs and outputs are configured as switches and lamps respectively.

* The inverter and I/O power supply cables are not shown.

 Required system components

The following table shows the minimum system requirements for this guide.

Equipment Description

Personal computer
Creates sequence programs and writes them to the inverter.

FR Configurator2 (Developer) (SW1DND-FRC2-E)

USB cable

Connects the personal computer and the inverter.

Recommended USB cable: MR-J3USBCBL3M (cable length 3 m)

Sequence start switch
Sequence program execution key.

Switches between RUN and STOP.

Input resistance 4.7 kΩ

Voltage when contacts are open: 
21 to 27 VDC

When contacts are short-circuited: 
4 to 6 mADC

Switch (input): 3
Connected to the external input terminal of 
the inverter.

Lamp (output): 3
Connected to the external output terminal 
of the inverter.

Permissible load 24 VDC 
(maximum 27 VDC) 0.1 A

(The voltage drop is 2.8 V at 
maximum while the signal is ON.)24 VDC power supply Power supply for the indicator lamps

Switch (input) Lamp (output)Inverter

USB cable

Lamp 1

Lamp 2

Lamp 3Switch 2

Switch 3

Switch 1

To personal computer

SQ signal

Connector for inverter
Mini B connector (5 pins)

Connector for personal 
computer
A connector
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4. Wiring of the inverter

Perform wiring of the inverter.

 Wiring of the power supply

The following shows an example of wiring of the power supply cables and the earthing (grounding) 

cable. Earthing (grounding) is performed to prevent electric shocks and malfunctions.

The terminal layout depends on the inverter capacity.

Always switch the inverter power OFF before performing inverter wiring work.

Reference

For the details of wiring, refer to the FR-A800 Instruction Manual (Detailed) (IB-0600503ENG).

Example of 0.4K

R/L1 S/L2 T/L3

P/+

PR

PX

Power
supply Earth

(ground)
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 Wiring of the I/O signals

The following shows an example of wiring of the I/O signal cables.

AM

2 5 4 SD SD S1 S2 PC A1 B1 C1 A2 B2 C2SICSOC

5 10E 10 FU PC RL RM RT AU CSSTP MRS JOG

Lamp  1
Signal: Y0

Lamp  2
Signal: Y1

Lamp  3
Signal: Y2

Switch 
Signal: SQ

Switch 1
Signal: X0

Switch 2
Signal: X1

Switch 3
Signal: X2

24VDC

Output
common

Input
common

SD

F/C +24 SO1

STRSTFSDRESRHOLSUSE

L

SE RUN

L L

IPF
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5. Checking power-ON

After the wiring is completed, check that the power is properly supplied to the inverter.

1. Checking before power-ON
• Wiring of the power supply

• Power supply voltage

• Check that the connected switches (page 7) are OFF.

2. Turning the power ON
Check that the LED indicator on the operation panel (FR-DU08) is ON.

3. Changing the inverter parameter settings
Perform parameter settings to use the PLC function.

 Enable the PLC function.

Set "2" in Pr.414 PLC function operation selection.

 Sequence start (SQ) signal input terminal setting (sequence program execution key (STOP/RUN) setting)

Set "50" in Pr.189.

 I/O terminal assignment change

Set "9999" in Pr.178, Pr.179, and Pr.182, and Pr.190, Pr.191, and Pr.192.

Setting "9999" for the I/O terminals enable the use of the terminals as general-purpose I/O terminals.

Consequently, the I/O terminals will be changed as follows.

Operating procedure

Pr.
Input terminal 
name

Device 
number

Pr.
Output 
terminal name

Device 
number

178 STF X0 190 RUN Y0

179 STR X1 191 SU Y1

182 RH X2 192 IPF Y2

Point

The SQ signal can be assigned to the terminals other than the terminal RES. For the SQ signal,

set "50" to any of Pr.178 to Pr.189 (input terminal function selection) to assign the function

to the inverter input terminal. (Refer to the Instruction Manual (Detailed) of the inverter for the

details.)

Terminology

Parameter: Setup information necessary to operate the inverter. By setting parameters, the

PLC function is enabled, or the complicated motor control can be achieved.
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Creating a sequence program

6. Programming

Create a program (sequence program) for sequence control.

For details, refer to the GX Works2 Version 1 Operating Manual (Common) (SH-080779ENG).

 "Devices" and "Instruction symbols" for programming

Combine "Devices" and "Instruction symbols" to create a sequence program.

1. Devices

Devices include two types: bit devices and word devices.

A bit device handles one-bit information such as the ON/OFF of a switch or a lamp.

Examples of bit devices

A word device handles 16-bit information such as numeric values and character strings.

Examples of word devices

Device name Device symbol Description

Input X Receives a signal from an external device such as a switch.

Output Y Outputs a signal to an external device such as a lamp.

Internal relay M Temporarily stores status data in programs.

Timer 
(contact)

T
Used to measure time.
(When the set time comes, the contact turns ON.)

Counter 
(contact)

C
Used to count the number of times the input condition turns from OFF to ON. 
(When the number of retries reaches the set number, the contact turns ON.)

Device name
Device 
symbol

Description

Data register D Stores numeric values and character strings.

Timer 
(present value)

T
Used to measure time.
(Stores the present time value being measured.)

Counter 
(present value)

C
Used to count the number of times the input condition turns from OFF to 
ON. (Stores the present count value being measured.)

Terminology

Device: An area to store data such as ON/OFF status, numeric values, and character strings for the

PLC function.

Internal relay: A device that shuts off/connects the sequence circuit by switching ON/OFF.

Contact: An input used for creating a sequence program.

• ON/OFF of a switch • ON/OFF of a lamp

• Numeric value • Character string
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Creating a sequence program

2. Instruction symbols

 Creating a program

Now, create a sequence program.

The following shows how to create a sequence program with basic devices and instruction symbols for 
sequence control.

The following devices and instruction symbols are used.
• Input: "X" device

• Output: "Y" device

• Instruction symbols: , , 

Create a program to perform the following controls.
• When both the X0 and X1 switches are turned ON, the Y0 output lamp turns ON.

• When the X2 switch is turned ON, both the Y1 and Y2 output lamps turn OFF.

The following explains the procedure to create this sequence program.

Instruction symbol Description

NO contact: Conducting when the input signal is ON.

NC contact: Conducting when the input signal is OFF.

Coil output: Data output to a specified device.

Terminology

Coil: An output used for creating a sequence program.

Reference

For the details of devices and instructions available for performing sequence control, refer to

the FR-A800 PLC Function Programming Manual (IB-0600492ENG).

X0

X1

X2

Y0

Y1

Y2
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Creating a sequence program

 Starting FR Configurator2 (Developer)

From the FR Configurator2 menu, select [Tool] → [Developer].

After startup, the main screen of FR Configurator2 (Developer) appears.

 Creating a new project

A project consists mainly of programs, device comments, and parameters.

 Select [Project] → [New].

 Select "FR-A800".

 Click the  button.

Operating procedure

Operating procedure
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Creating a sequence program

A project tree and a ladder screen appear.

 Creating a sequence program

1. Entering 

 Click the area to enter.

 Click .

 Enter "X0" on the ladder input screen, and then click the  button.

2. Entering 

 Click the area to enter.

 Click .

 Enter "X1" on the ladder input screen, and then click the  button.

Ladder screen

Project tree

Operating procedure

X0

X1
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Creating a sequence program

3. Entering 

 Click the area to enter.

 Click .

 Enter "Y0" on the ladder input screen, and then click the  button.

Coil Y0 appears.

4. Entering 

 Click the area to enter.

 Click .

 Enter "X2" on the ladder input screen, and then click the  button.

Y0

X2
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Creating a sequence program

5. Entering 

 Click the area to enter.

 Click .

 Enter "Y1" on the ladder input screen, and then click the  button.

Coil Y1 appears.

6. Drawing a line

 Click the area to enter, and press  +  and then  + . 

Y1

Ctrl Ctrl
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Creating a sequence program

7. Entering 

 Click the area to enter.

 Click .

 Enter "Y2" on the ladder input screen, and then click the  button.

Coil Y2 appears.

 Converting a program

Confirm the contents of the entered ladder block.

 Select [Compile] → [Build].

Perform the conversion to align entered ladders. When the conversion is completed, the gray display turns white.

[Before conversion]

[After conversion]

The programming is completed.

Operating procedure

Y2

The ladder is left-aligned.



3

C
re

at
in

g
 a

 s
eq

u
en

ce
 p

ro
g

ra
m

16

Creating a sequence program

 Saving a project

Save the created program in a project.

 Select [Project] → [Save As].

The "Save As" window appears.

 Specify the save location.

 Enter the file name and the title.

 Click the  button.

 Click the  button.

The project is saved.

Point

Buttons on the toolbar or short-cut keys on the keyboard can also be used for editing programs.

Operating procedure

Editing Toolbar Short-cut key

NO contact

NC contact

Drawing lines

Inputting vertical lines
 + 

 +  / 

Inputting horizontal lines

 +  / 

Inputting horizontal lines continually -  +  +  / 

F5

F6

F10

Shift F9

Ctrl

F9

Ctrl

Ctrl Shift
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Creating a sequence program

7. Writing a program to the inverter

Write the created program to the inverter.

1. Connecting the inverter and the personal computer
Connect the inverter and the USB port of the personal computer with a USB cable.

Connect the USB cable to the USB device (mini B connector) on the inverter.

2. Turning ON the inverter
Turn the power ON to energize the inverter.

3. Setting the connection between FR Configurator2 (Developer) and the 
inverter

 Click [Connection Destination].

 Double-click the data name to be transferred.

The "Transfer Setup" window appears.

Operating procedure

Personal computer Inverter

USB device
(Mini B connector)
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Creating a sequence program

 Double-click "Serial USB".

The "PC side I/F Serial Setting" window appears.

 Select "USB".

 Click the  button.

 Click "Main Module".

 Click "No Specification".

 Click the  button.

When the connection is properly established, the connection completion message appears.

 Click the  button.

 Click the  button.

The connection setting is completed.

Point

If the window shown below appears after Step , check that the USB driver has been installed

correctly and that an appropriate connection cable (USB cable) is used.
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Creating a sequence program

4. Writing a program to the inverter

 Select [Online] → [Write to PLC].

The "Online Data Operation" window appears.

 Click "Parameter + Program". "Program" and "Parameter" are marked.

 Click .

When the "Write to PLC" function is completed successfully, the following message appears.

 Click .

The program writing is completed.

Click the  button to close the "Online Data Operation" window.
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Creating a sequence program

8. Checking the operation

Execute the program written to the inverter to check the operation.

Check the program operation with the switches and lamps or the monitor function of FR Configurator2 
(Developer).

 Executing the program written to the inverter

Use the switch between terminals RES (SQ) and SD of the inverter.

[How the STOP/RUN switch is used]

• Switch ON: RUN (SQ signal ON).....................Executes the sequence program operation.

• Switch OFF: STOP (SQ signal OFF) ...............Stops the sequence program operation.

1. Executing the program
Turn ON the STOP/RUN switch (SQ signal).

2. Using the operation panel to check the operation
The sequence program operating (RUN) status can be checked with the operation panel (FR-DU08).

Operating procedure

FR-DU08

P.RUN state PLC function operation

OFF (normal indication) Sequence program stopped

ON (inverted indication) Sequence program running

Flickering Sequence error occurring

PLC function indicator

FWD

REV

STOP
RESET

REV

FWD

STOP
RESET

P.RUN

PU
EXT
NET

MON
PRM

IM
PM
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Creating a sequence program

 Using switches and FR Configurator2 (Developer) to check the operation

Check the program operation using the monitor mode of FR Configurator2 (Developer) by operating the 

switches ON/OFF.

1. Using the monitor mode screen of the operating program
Select [Online] → [Monitor] → [Start Monitoring].

When monitoring is performed, the "Monitor Status" screen appears.

You can see the ON/OFF state of the bit devices on the ladder screen.

An ON-state contact or output is shown in blue.

Right after the execution of the program, bit devices X2, Y1, and Y2 are ON and shown in blue.

2. Operation check 1

 Turn ON the switch (X0) between terminals STF and SD of the inverter. → X0 turns ON.

3. Operation check 2

 Turn ON the switch (X1) between terminals STR and SD of the inverter. → X1 turns ON and Y0 turns ON.

4. Operation check 3

 Turn ON the switch (X2) between terminals RH and SD of the inverter. → X2 turns OFF and Y1 and Y2 turn

OFF.

Operating procedure

Blue illumination
Blue illumination

X0 X1

X2

Y1

Y2

X0

X1

X2

Y0

Y1-ON

Y2-ON

Blue illumination

X0 X1

X2

Y1

Y2

X0-ON

X1

X2

Y0

Y1-ON

Y2-ON

Blue illumination Blue illumination

X0 X1

X2

Y1

Y2

X0-ON

X1-ON

X2

Y0-ON

Y1-ON

Y2-ON

Turns off. Turns off.

X0 X0

X2

Y1

Y2

X0-ON

X1-ON

X2-ON

Y0-ON

Y1

Y2
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Useful functions
This section describes functions frequently used in FR Configurator2 (Developer).

9. Making a program easy to understand <Comment>

Use comments to make the program easy to understand.

The following are the three types of comment.

Type Description Number of characters

Device comment Describes roles and applications of each device. 32

Statement Describes roles and applications of ladder blocks. 64

Note
Describes roles and applications of output 
instructions.

32

Point

Select [View] → [Comment] (  key +  key) to switch between displaying/hiding of

comments.

Statement

Device comment

Note

Ctrl F5
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Useful functions

 Creating device comments

Device comments can be entered from the list or on the ladder diagram.

 Double-click [Global Device Comment] in the project list.

 Enter the start device number in the "Device Name" field and press the  key.

 Enter a comment in the "Comment" field.

* When entering comments for other devices, repeat Steps  and .

<Input operation from the list>

Operating procedure

Double-click

Enter

Input

Input
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Useful functions

 Select [Edit] → [Documentation] → [Device Comment].

 Double-click the ladder symbol to enter a comment.

 Enter a comment on the "Input Device Comment" window.

 Click the  button.

 To finish the operation, select the [Device Comment] menu in Step  again.

<Input operation on the ladder diagram>

Operating procedure

Select

Click

Double-click

Input
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Useful functions

 Select [Tool] → [Options].

 Select "Program Editor" → "Ladder1" → "Enter ladder".

 Select "Enter label comment and device comment".

 Click the  button.

After the ladder entry operation, the "Input Device Comment" window appears and a comment can be entered.

<Entering comments when creating ladders>

Operating procedure

Select

Click

Click

Check

Input
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Useful functions

 Creating statements

 Select [Edit] → [Documentation] → [Statement].

 Double-click a ladder symbol to enter a statement.

 Select "In PLC".

 Enter a statement.

 Click the  button.

 The statement appears on the ladder diagram.

 To finish the operation, select the [Statement] menu in Step  again.

If a statement is entered, the program needs to be "converted" to reflect the input. For details on the

conversion, refer to page 15.

Operating procedure

Select

Select

Double-click

Point

The following are the two types of statement.

● "In PLC"

Integrated statements can be written to/read from the inverter.

● "In Peripheral"

The program memory capacity can be saved since peripheral statements are not written to the

inverter. "*" is prefixed to the peripheral statement in the program.

Input Click



27

Useful functions

 Creating notes

 Select [Edit] → [Documentation] → [Note].

 Double-click an output instruction to enter a note.

 Select "In PLC".

 Enter a note.

 Click the  button.

 The note appears on the ladder diagram.

 To finish the operation, select the [Note] menu in Step  again.

If a note is entered, the program needs to be "converted" to reflect the input. For details on the conversion,

refer to page 15.

Operating procedure

Point

The following are the two types of note.

● "In PLC"

Integrated notes can be written to/read from the inverter.

● "In Peripheral"

The program memory capacity can be saved since peripheral notes are not written to the inverter.
"*" is prefixed to the peripheral note in the program.

Select

Double-click

Select

Input Click
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Useful functions

10. Monitoring the device value/status <Device monitor>

The following are the two types of device monitor.

 Device batch monitor

Consecutive devices are monitored by specifying the start device number.

 Select [Online] → [Monitor] → [Device Batch Monitor].

 Enter the start device number to be monitored and press the  key.

The values of devices and the ON/OFF status of contacts/coils are displayed.

Type Purpose

Device batch monitor Used to monitor consecutive devices of one type.

Watch
Used to monitor devices away from one another on the ladder 
or devices of different types in one window at the same time.

Operating procedure

Point

The device batch monitor function can be used to change the present value or the display

format.

Select

Enter

Input
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Useful functions

 Watch

To perform the Watch, specify target devices or the range of the ladder diagram for device registration.

 The status of devices can be displayed in watch windows 1 to 4.

Register specified devices in Watch 1.

 Select [Online] → [Monitor] → [Start Monitoring].

 Select [View] → [Docking Window] → [Watch1].

* Watch 1 window appears on the bottom right on the screen.

 Double-click a "Device/Label" field.

 Enter the device/label to be registered and press the  key.

 Select [Online] → [Watch] → [Start Watching].

The values of devices and the ON/OFF status of contacts/coils are displayed.

<Specified device registration>

Select

Select

Double-click

Enter

Input

Select
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Useful functions

Specify the range of the ladder diagram on the ladder monitor screen and batch register the devices in the range.

 Select [Online] → [Monitor] → [Start Monitoring].

 Select [View] → [Docking Window] → [Watch1].

 Click the start point of the ladder.

 While pressing the  key, click the end point of the ladder. → The range is specified.

<Device registration during ladder monitor display>

Select

Select

Shift

Click

+ ClickShift
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Useful functions

Register devices to the Watch.

 Drag and drop the selected range to watch 1 window.

Position the mouse pointer to the outside frame of the selected range. When  appears, start dragging.

The values of the selected devices are monitored.

 Select [Online] → [Watch] → [Start Watching].

Drag

Select
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Useful functions

11. Changing the device value <Device test>

This function is used to change the present values of word devices (such as T, C, or D) or bit devices (X or Y).

 Word device present value change

Change the present value of the word device (such as T, C, or D) in the inverter to the specified value.

 Select [Online] → [Monitor] → [Start Monitoring].

 Select [Debug] → [Modify Value].

 Enter the device number to be changed.

 Select "Word[Signed]".

 Enter the value to be changed.

 Click the  button.

Operating procedure

Select

Select

Input

ClickInput

Select



33

Useful functions

12. Checking errors <Error jump>

If an error occurs, you can checked the error with PLC diagnostics. By using the error jump, the cursor jumps 
to the step number of the sequence program corresponding to the error.

 PLC diagnostics

The details of an error can be checked in the PLC diagnostics.

 Select [Diagnostics] → [PLC Diagnostics].

PLC diagnostics screen (example)

 Click the [Error Help] button of the current error or the error history.

The details of the error and remedies appear.

Help screen (example)

Operating procedure

Select

Click either one
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Useful functions

 Error jump

Errors can be checked easily with the error jump function of PLC diagnostics.

 Select [Diagnostics] → [PLC Diagnostics].

 Click the [Error Jump] button of the current error or the error history.

The cursor jumps to the step number of the sequence program corresponding to the selected error.

Operating procedure

Select

Click either one
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